add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / abiword / abiword-plugins_2.6.0.bb
1 DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
2 HOMEPAGE = "http://www.abiword.org"
3 SECTION = "x11/office"
4 LICENSE = "GPLv2"
5 DEPENDS = "boost loudmouth libwpd librsvg goffice poppler libglade"
6 RDEPENDS = "abiword"
7
8 SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
9            http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
10            file://abiword-cxx-for-ld-fix.patch;patch=1 \
11            "
12
13 DEFAULT_PREFERENCE = "2"
14
15 inherit autotools
16
17 PARALLEL_MAKE=""
18
19 # Ugly hack to find libstdc++
20 export LD="${CXX}"
21
22 EXTRA_OECONF = " --without-libwmf \
23                  --without-inter7eps \
24                  --with-abiword=${WORKDIR}/abiword-${PV} \
25                  --with-boost=${STAGING_DIR_HOST} \ 
26                  --with-boost-thread=boost_thread-mt \
27                "
28
29 PACKAGES_DYNAMIC = "abiword-plugin-*"
30
31 python populate_packages_prepend () {
32         abiword_libdir    = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
33         do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
34         do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
35 }
36
37
38 PACKAGES =+ "abiword-plugin-collab-glade"
39
40 FILES_abiword-plugin-collab-glade += "${datadir}"
41 RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
42
43 FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
44