Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / abiword / abiword-plugins_2.5.1.bb
1 DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
2 HOMEPAGE = "http://www.abiword.org"
3 SECTION = "x11/office"
4 LICENSE = "GPLv2"
5 DEPENDS = "libwpd librsvg goffice poppler libglade"
6 RDEPENDS = "abiword"
7
8 PR = "r1"
9
10 DEFAULT_PREFERENCE = "-1"
11
12 SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
13            http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
14            "
15
16 inherit autotools
17
18 PARALLEL_MAKE=""
19
20 EXTRA_OECONF = " --without-libwmf \
21                  --without-inter7eps \
22                  --with-abiword=${WORKDIR}/abiword-${PV} \
23                  "
24
25 PACKAGES_DYNAMIC = "abiword-plugin-*"
26
27 python populate_packages_prepend () {
28         abiword_libdir    = bb.data.expand('${libdir}/abiword-2.5/plugins', d)
29         do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
30         do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
31 }
32
33
34 PACKAGES =+ "abiword-plugin-collab-glade"
35
36 FILES_abiword-plugin-collab-glade += "${datadir}"
37 RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
38
39 FILES_${PN}-dbg += "${libdir}/abiword-2.5/plugins/.debug"
40