increase dvbapp PR.
[vuplus_openembedded] / recipes / abiword / abiword-plugins_2.4.6.bb
1 DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word""
2 HOMEPAGE = "http://www.abiword.org""
3 SECTION = "x11/office"
4 LICENSE = "GPLv2"
5 DEPENDS = "libwpd librsvg goffice poppler"
6 RDEPENDS = "abiword"
7
8 PR = "r1"
9
10 SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
11            file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
12 S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
13
14 inherit autotools
15
16 PARALLEL_MAKE=""
17
18 EXTRA_OECONF = "--without-libwmf --without-inter7eps"
19
20 PACKAGES_DYNAMIC = "abiword-plugin-*"
21
22 python populate_packages_prepend () {
23         abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
24
25         do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
26 }
27