zroadmap: Make sure we install desktop shortcut under Applications, not
[vuplus_openembedded] / packages / zroadmap / zroadmap_1.0.12.bb
1 DESCRIPTION = "RoadMap is a program that provides a car navigation for Linux and UNIX. \
2 It displays a map of the streets, tracks the position provided by a NMEA-compliant \
3 GPS receiver, identifies the street matching this GPS position and announces the name \
4 of the crossing street at the next intersection. A rudimentary trip feature allows \
5 RoadMap to display some basic navigation information (distance to the destination, \
6 direction, speed, etc..). Voice messages are generated that duplicate some of the screen information."
7 SECTION = "opie/applications"
8 PRIORITY = "optional"
9 AUTHOR = "Pascal Martin <pascal.martin@iname.com>"
10 HOMEPAGE = "http://roadmap.digitalomaha.net/maps.html"
11 LICENSE = "GPL"
12 PR = "r0"
13
14 SRC_URI = "http://www.roadmap.digitalomaha.net/roadmap/roadmap_1_0_12p2_src.tar.gz \
15            file://qt2-fixes.patch;pnum=2;patch=1 \
16            http://roadmap.digitalomaha.net/maps/usdir.rdm.tgz \
17            file://zroadgps.png"
18 S = "${WORKDIR}/roadmap-${PV}/src"
19
20 inherit palmtop
21
22 QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'
23 QT_LIBRARY_append_c7x0 = " -laticore"
24
25 EXTRA_OEMAKE = 'DESKTOP=QPE MOC=${OE_QMAKE_MOC} UIC=${OE_QMAKE_UIC} \
26                 GUICFLAGS="-I${OE_QMAKE_INCDIR_QT} -I${S} -DQWS" \
27                 GUILDFLAGS="-lz -lpng -ljpeg -lts -l${QT_LIBRARY} -lqpe -Wl,-rpath-link,${STAGING_LIBDIR} -L${STAGING_LIBDIR} -L${QTDIR}/lib"'
28 PARALLEL_MAKE = ""
29
30 do_configure() {
31         echo removing pregenerated stuff
32         find . -name "moc*"|xargs rm -f
33 }
34
35 do_compile() {
36         oe_runmake libguiroadmap.a libguiroadgps.a libroadmap.a unix/libosroadmap.a
37         cd qt && oe_runmake
38 }
39
40 do_install() {
41         cd qt
42         install -d ${D}${palmtopdir}/bin
43         install -d ${D}${palmtopdir}/apps/Applications
44         install -d ${D}${palmtopdir}/pics
45         install -m 0755 qtroadmap ${D}${palmtopdir}/bin/roadmap
46         install -m 0755 qtroadgps ${D}${palmtopdir}/bin/roadgps
47         install -m 0644 ../roadmap.png ${D}${palmtopdir}/pics/zroadmap.png
48         install -m 0644 ${WORKDIR}/zroadgps.png ${D}${palmtopdir}/pics/zroadgps.png
49         install -m 0644 ipkg/*.desktop ${D}${palmtopdir}/apps/Applications/
50         install -d ${D}${palmtopdir}/share/roadmap/
51         install -m 0644 ../sprites ../schema ../preferences ${D}${palmtopdir}/share/roadmap/
52         install -m 0644 ${WORKDIR}/usdir.rdm ${D}${palmtopdir}/share/roadmap/
53 }