merge of '30c320b2f51c86226580e5bbf68fa8b0896a0655'
[vuplus_openembedded] / packages / zope / zope_3.3.1.bb
1 DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 DEPENDS = "python"
5 RDEPENDS = "python-core python-shell"
6 LICENSE = "ZPL"
7 PR = "r2"
8
9 SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
10
11 S = "${WORKDIR}/Zope-${PV}"
12
13 do_configure() {
14         ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
15 }
16
17 do_compile() {
18         oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
19 }
20
21 do_install() {
22         oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
23 }
24
25 PACKAGES =+ "python-zopeinterface python-zopeinterface-dbg"
26
27 FILES_${PN} = "${prefix}"
28 FILES_${PN}_doc = "${prefix}/doc"
29 FILES_${PN}-dbg += "\
30 ${libdir}/python/BTrees/.debug \
31 ${libdir}/python/persistent/.debug \
32 ${libdir}/python/zope/proxy/.debug \
33 ${libdir}/python/zope/thread/.debug \
34 ${libdir}/python/zope/security/.debug \
35 ${libdir}/python/zope/hookable/.debug \
36 ${libdir}/python/zope/app/container/.debug \
37 ${libdir}/python/zope/i18nmessageid/.debug \
38 ${libdir}/python/ZODB/.debug"
39 FILES_python-zopeinterface-dbg += "${libdir}/python/zope/interface/.debug "
40
41 FILES_python-zopeinterface = "${libdir}/python/zope/interface/*.* ${libdir}/python/zope/interface/common"