conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / zope / zope_2.9.2.bb
1 DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 DEPENDS = "python"
5 RDEPENDS = "python-core python-shell"
6 LICENSE = "ZPL"
7 PR = "ml0"
8
9 SRC_URI = "http://zope.org/Products/Zope/${PV}/Zope-${PV}.tgz"
10 S = "${WORKDIR}/Zope-${PV}"
11
12 do_configure() {
13         ./configure --with-python=${STAGING_BINDIR}/python --prefix=${prefix} --force
14 }
15
16 do_compile() {
17         oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
18 }
19
20 do_install() {
21         oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
22 }
23
24 FILES_${PN} = "${prefix}"
25 FILES_${PN}_doc = "${prefix}/doc"