Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / zddice / zddice_1.0.0.bb
1 DESCRIPTION = "Zaurus D20 Gaming Dice for Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 FILE_PR = "r1"
6
7 SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zddice/zddice_${PV}_arm.src.tar.gz \
8            file://qtopia17.patch;patch=1"
9 S = "${WORKDIR}/zddice-src"
10
11 inherit palmtop
12
13 EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
14
15 do_install() {
16         install -d ${D}${palmtopdir}/{bin,pics,apps/Games}
17         install -m 0755 zddice ${D}${palmtopdir}/bin/
18         install -m 0644 images/zddice.png ${D}${palmtopdir}/pics/
19         install -m 0644 zddice.desktop ${D}${palmtopdir}/apps/Games/
20 }