Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / zaurusd / zaurusd_svn.bb
1 DESCRIPTION = "Daemon to handle device specifc features."
2 SECTION = "base"
3 LICENSE = "GPL"
4 DEPENDS = "tslib"
5 RDEPENDS = "procps"
6 PV = "0.0+svn${SRCDATE}"
7 PR = "r17"
8
9 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
10            file://zaurus-hinge.in \
11            file://add-poodle.patch;patch=1 \
12            file://alsa-cxx00-default.state.patch;patch=1 \
13            file://alsa-6000x-default.state.patch;patch=1 \
14            file://disable-alsa-handling.patch;patch=1 \
15            file://zaurus-hinge.matchbox-portrait \         
16            file://zaurus-hinge.matchbox-landscape \
17            file://tslib-1.diff;patch=1 \
18            file://zaurus-hinge.bl-on \
19            file://zaurus-hinge.bl-off \
20            file://01-check-toggle-landscape \
21            file://01-check-toggle-portait"
22
23
24 S = "${WORKDIR}/${PN}"
25
26 PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28 do_configure_prepend () {
29         cp ${WORKDIR}/zaurus-hinge.in ${S}/scripts
30 }
31
32 do_install_append() {
33         install -d "${D}/etc/zaurusd/hinge-landscape.d"
34         install -d "${D}/etc/zaurusd/hinge-portrait.d"
35         install -d "${D}/etc/zaurusd/hinge-close.d"
36         install -d ${D}/etc/apm/resume.d
37
38         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/apm/resume.d/00-backlight-on"
39         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-landscape.d/00-backlight-on"
40         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-portrait.d/00-backlight-on"
41         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-off" "${D}/etc/zaurusd/hinge-close.d/00-backlight-off"
42
43         install -m 0755 "${WORKDIR}/01-check-toggle-landscape" "${D}/etc/zaurusd/hinge-landscape.d/01-check-toggle"
44         install -m 0755 "${WORKDIR}/01-check-toggle-portait" "${D}/etc/zaurusd/hinge-portrait.d/01-check-toggle"
45
46         install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-landscape" "${D}/etc/zaurusd/hinge-landscape.d/20-matchbox-landscape"
47         install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-portrait" "${D}/etc/zaurusd/hinge-portrait.d/20-matchbox-portrait"
48 }
49
50 inherit autotools pkgconfig update-rc.d
51
52 INITSCRIPT_NAME = "zaurusd"
53 INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."