merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / xorg-xserver / xserver-kdrive_1.4.2.bb
1 require xserver-kdrive-common.inc
2
3 DEPENDS += "hal libxkbfile libxcalibrate pixman"
4
5 PE = "1"
6
7 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
8         ${KDRIVE_COMMON_PATCHES} \
9         file://enable-epson.patch;patch=1 \
10         file://fix_default_mode.patch;patch=1 \
11         file://enable-xcalibrate.patch;patch=1 \
12         file://hide-cursor-and-ppm-root.patch;patch=1 \
13         file://xcalibrate_coords.patch;patch=1 \
14         file://w100.patch;patch=1 \
15         file://w100-autofoo.patch;patch=1 \
16         file://w100-fix-offscreen-bmp.patch;patch=1 \
17         file://w100-new-input-world-order.patch;patch=1 \
18         file://linux-keyboard-mediumraw.patch;patch=1 \
19         file://xcalibrate-new-input-world-order.patch;patch=1 \
20         file://tslib-default-device.patch;patch=1 \
21         file://fbdev-evdev.patch;patch=1 \
22         file://keyboard-resume-workaround.patch;patch=1 \
23         file://xorg-avr32-support.diff;patch=1 \
24         file://pkgconfig_fix.patch;patch=1 \
25         file://no_xkb.patch;patch=1;pnum=0 \
26         "
27
28 S = "${WORKDIR}/xorg-server-${PV}"
29
30 W100_OECONF = "--disable-w100"
31 W100_OECONF_arm = "--enable-w100"
32
33 EXTRA_OECONF += "--enable-builtin-fonts"