merge of '0b604857bbf871639fdb43ee8380222e8ef64bb7'
[vuplus_openembedded] / packages / xorg-xserver / xserver-kdrive-glamo_1.3.0.0+git.bb
1 DESCRIPTION = "X server for glamo chip in GTA02"
2 SECTION = "x11/base"
3 LICENSE = "MIT"
4 DEPENDS = "compositeproto damageproto fixesproto recordproto resourceproto \
5            scrnsaverproto xineramaproto videoproto xextproto xproto \
6            libxau libxext libxdmcp libxfont libxrandr tslib virtual/libx11 \
7            xtrans libxkbfile libxcalibrate"
8 DEPENDS += "libxkbfile libxcalibrate"
9 RDEPENDS_${PN} = "xserver-kdrive"
10 PROVIDES = "virtual/xserver"
11 PE = "1"
12 PR = "r1"
13
14 XGLAMO_GIT_REV = "0d2605edeb50a4b118ac00ae1f00abd085477323"
15
16 SRC_URI = "git://people.freedesktop.org/~dodji/xglamo;protocol=git;rev=${XGLAMO_GIT_REV} \
17         file://kmode.patch;patch=1 \
18         file://disable-apm.patch;patch=1 \
19         file://no-serial-probing.patch;patch=1 \
20         file://fbdev-not-fix.patch;patch=1  \
21         file://optional-xkb.patch;patch=1 \
22         file://enable-tslib.patch;patch=1 \
23         file://kmode-palm.patch;patch=1 \
24         file://enable-epson.patch;patch=1 \
25         file://enable-builtin-fonts.patch;patch=1 \
26         file://kdrive-evdev.patch;patch=1  \
27         file://kdrive-use-evdev.patch;patch=1  \
28         file://disable-xf86-dga-xorgcfg.patch;patch=1 \
29         file://fix_default_mode.patch;patch=1 \
30         file://enable-xcalibrate.patch;patch=1 \
31         file://hide-cursor-and-ppm-root.patch;patch=1 \
32         file://xcalibrate_coords.patch;patch=1 \
33         file://w100.patch;patch=1 \
34         file://w100-autofoo.patch;patch=1 \
35         file://w100-fix-offscreen-bmp.patch;patch=1 \
36         file://kdrive-1.3-18bpp.patch;patch=1 \
37         file://gumstix-kmode.patch;patch=1 \
38 "
39
40 FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-1.3.0.0:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
41
42 S = "${WORKDIR}/git"
43
44 inherit autotools pkgconfig
45
46 EXTRA_OECONF = "--enable-composite --enable-kdrive \
47                 --disable-dga --disable-dri --disable-xinerama \
48                 --disable-xf86misc --disable-xf86vidmode \
49                 --disable-xorg --disable-xorgcfg \
50                 --disable-xkb --disable-xnest --disable-xvfb \
51                 --disable-xevie --disable-xprint --disable-xtrap \
52                 --disable-dmx \
53                 --with-default-font-path=built-ins \
54                 --enable-tslib --enable-xcalibrate \
55                 ac_cv_file__usr_share_X11_sgml_defs_ent=no"
56
57 do_configure_prepend() {
58     sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
59 }
60
61 FILES_${PN} = "${bindir}/Xglamo"
62 FILES_${PN}-dbg = "${bindir}/.debug/Xglamo"
63
64 ARM_INSTRUCTION_SET = "arm"