merge of '8c185e14edc5b4a26b15fd54f158e22f3f659282'
[vuplus_openembedded] / packages / wesnoth / wesnoth_1.4.5.bb
1 DESCRIPTION = "The Battle for Wesnoth is a turn-based strategy game with a fantasy theme."
2 HOMEPAGE = "http://www.wesnoth.org/"
3 SECTION = "games"
4 LICENSE = "GPL"
5
6 DEPENDS = "freetype libsdl-image libsdl-mixer libsdl-net libsdl-ttf zlib boost imagemagick-native"
7
8 PR = "r0"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/wesnoth/${PN}-${PV}.tar.bz2"
11
12 EXTRA_OECONF = "\
13         --enable-tinygui \
14         --enable-editor \
15         --enable-lite \
16         --enable-lowmem \
17         --with-boost=${STAGING_INCDIR} \
18         --with-freetype=${STAGING_INCDIR} \
19         --without-fribidi \
20         --disable-python \
21 "
22
23 inherit autotools
24
25 PACKAGES = "wesnoth-editor wesnoth-doc wesnoth-music \
26         wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
27         wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
28         wesnoth-tsg wesnoth-tb wesnoth-utbs \
29         wesnoth-data \
30         wesnoth-all \
31         wesnoth wesnoth-dbg \
32         "
33
34 do_install_append() {
35         if [ -f ${D}${datadir}/wesnoth/icons ]; then
36                 rm -rf ${D}${datadir}/wesnoth/icons
37         fi
38 }
39
40 RDEPENDS_wesnoth = "wesnoth-data"
41
42 RDEPENDS_wesnoth-editor = "wesnoth-data"
43
44 RDEPENDS_wesnoth-all = "wesnoth wesnoth-music \
45         wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
46         wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
47         wesnoth-tsg wesnoth-tb wesnoth-utbs"
48
49 # Installing wesnoth-all should pull everything in (like in Debian).
50 ALLOW_EMPTY_${PN}-all = "1"
51
52 FILES_wesnoth-music = "\
53         ${datadir}/wesnoth/data/core/music \
54 "
55
56 # Picks up remaining translations and data. Must be packaged after
57 # wesnoth-music and all campaigns.
58 FILES_wesnoth-data = "\
59   ${datadir}/wesnoth/sounds \
60   ${datadir}/wesnoth/images \
61   ${datadir}/wesnoth/data \
62   ${datadir}/wesnoth/fonts \
63   ${datadir}/wesnoth/translations \
64 "
65
66 FILES_${PN} = "\
67   ${bindir}/wesnoth \
68         ${datadir}/icons \
69         ${datadir}/applications \
70 "
71
72 FILES_wesnoth-editor = "\
73         ${bindir}/wesnoth_editor \
74 "
75
76 FILES_wesnoth-aoi = "\
77         ${datadir}/wesnoth/data/campaigns/An_Orcish_Incursion \
78         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-aoi.mo \
79 "
80
81 FILES_wesnoth-did = "\
82         ${datadir}/wesnoth/data/campaigns/Descent_Into_Darkness \
83         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-did.mo \
84 "
85
86 FILES_wesnoth-ei = "\
87         ${datadir}/wesnoth/data/campaigns/Eastern_Invasion \
88         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-ei.mo \
89 "
90
91 FILES_wesnoth-httt = "\
92         ${datadir}/wesnoth/data/campaigns/Heir_To_The_Throne \
93         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-httt.mo \
94 "
95
96 FILES_wesnoth-l = "\
97         ${datadir}/wesnoth/data/campaigns/Liberty \
98         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-l.mo \
99 "
100
101 FILES_wesnoth-nr = "\
102         ${datadir}/wesnoth/data/campaigns/Northern_Rebirth \
103         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-nr.mo \
104 "
105
106 FILES_wesnoth-sof = "\
107         ${datadir}/wesnoth/data/campaigns/Sceptre_Of_Fire \
108         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sof.mo \
109 "
110
111 FILES_wesnoth-sotbe = "\
112         ${datadir}/wesnoth/data/campaigns/Son_Of_The_Black_Eye \
113         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sotbe.mo \
114 "
115
116 FILES_wesnoth-thot = "\
117         ${datadir}/wesnoth/data/campaigns/The_Hammer_Of_Thursagan \
118         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-thot.mo \
119 "
120
121 FILES_wesnoth-trow = "\
122         ${datadir}/wesnoth/data/campaigns/The_Rise_Of_Wesnoth \
123         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-trow.mo \
124 "
125
126 FILES_wesnoth-tsg = "\
127         ${datadir}/wesnoth/data/campaigns/The_South_Guard \
128         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tsg.mo \
129 "
130
131 FILES_wesnoth-tb = "\
132         ${datadir}/wesnoth/data/campaigns/Two_Brothers \
133         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tb.mo \
134 "
135
136 FILES_wesnoth-utbs = "\
137         ${datadir}/wesnoth/data/campaigns/Under_the_Burning_Suns \
138         ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-utbs.mo \
139 "