Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / vorbis-tools / vorbis-tools_1.0.1.bb
1 DESCRIPTION = "vorbis-tools contains oggenc (an encoder), ogg123 (a playback tool), \
2 ogginfo (displays ogg information), vcut (ogg file splitter), and \
3 vorbiscomment (ogg comment editor)."
4 LICENSE = "GPL"
5 DEPENDS = "libogg libvorbis libao curl"
6 SECTION = "console/multimedia"
7 FILE_PR = "r1"
8
9 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/vorbis-tools-${PV}.tar.gz \
10            file://m4.patch;patch=1 \
11            file://remove-deprecated-curl-option.patch;patch=1"
12
13 inherit autotools
14
15 EXTRA_OECONF = "--without-flac --without-speex \
16                 --with-ogg-libraries=${STAGING_LIBDIR}/ \
17                 --with-ogg-includes=${STAGING_INCDIR}/ \
18                 --with-vorbis-libraries=${STAGING_LIBDIR}/ \
19                 --with-vorbis-includes=${STAGING_INCDIR}/ \
20                 --with-ao-libraries=${STAGING_LIBDIR}/ \
21                 --with-ao-includes=${STAGING_INCDIR}/ \
22                 --with-curl-libraries=${STAGING_LIBDIR}/ \
23                 --with-curl-includes=${STAGING_INCDIR}/"