rootfs_ipk.bbclass: fix string comparison
[vuplus_openembedded] / packages / vlc / vlc_0.9.2.bb
1 DESCRIPTION = "Video player and streamer - davinci edition"
2 HOMEPAGE = "http://www.videolan.org"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 SECTION = "multimedia"
6
7 PR = "r1"
8
9 DEPENDS = "libtool hal gettext libgcrypt schroedinger libsdl-x11 qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac liba52 libid3tag libmad mpeg2dec"
10
11 SRC_URI = "http://videolan.mirror.technotop.nl/vlc/0.9.2/vlc-${PV}.tar.bz2"
12
13 inherit autotools
14
15 EXTRA_OECONF = "\
16         --enable-libtool \
17         --with-contrib \
18         --disable-dvdread \
19         --disable-wxwidgets \
20         --enable-x11 --enable-xvideo \ 
21         --disable-screen --disable-caca \
22         --enable-httpd --enable-vlm \
23         --enable-freetype \
24         --enable-sdl \ 
25         --enable-png \
26         --enable-live555 --enable-tremor \
27         --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \
28         --enable-dbus \
29         --enable-hal \  
30         --without-contrib \
31         ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
32         ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
33         ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
34 "
35
36
37 do_configure() {
38         cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/ 
39         ./bootstrap     
40         gnu-configize --force
41         libtoolize --force
42         #autoreconf --force -i
43         cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/
44         oe_runconf
45         rm config.log
46         sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
47         sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
48 }
49
50 do_stage() {
51         autotools_stage_all
52 }
53
54
55 FILES_${PN} += "${bindir}/vlc \
56         ${datadir}/applications \
57         ${datadir}/vlc/ \
58         "
59
60 FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"