rootfs_ipk.bbclass: fix string comparison
[vuplus_openembedded] / packages / vlc / vlc-davinci_0.8.6h.bb
1 DESCRIPTION = "Video player and streamer - davinci edition"
2 HOMEPAGE = "http://www.videolan.org"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 SECTION = "multimedia"
6
7 SRCREV = "e712a114e04a1070f1afdf31ec668cb28eda513c"
8
9 PR = "r5"
10
11 PV = "0.8.6h+${PR}+gitr${SRCREV}"
12
13 DEPENDS = "codec-engine dbus libxml2 gnutls tremor faad2 ffmpeg flac liba52 libid3tag libmad mpeg2dec"
14
15 SRC_URI = "git://git.videolan.org/vlc.git;protocol=git;branch=0.8.6-neuros"
16
17 S = "${WORKDIR}/git"
18
19 inherit autotools
20
21 EXTRA_OECONF = "\
22     --enable-libtool \
23         --with-contrib \
24         --disable-dvdread \
25         --disable-wxwidgets \
26     --disable-skins2 \
27         --disable-libmpeg2 \
28     --disable-dvdnav \
29         --disable-x11 --disable-xvideo --disable-opengl --disable-glx \
30         --disable-screen --disable-caca \
31         --disable-httpd --disable-vlm \
32         --disable-freetype \
33     --disable-sdl \ 
34     --enable-png \
35         --enable-live555 --enable-tremor \
36     --disable-mod \
37         --enable-davinci --enable-davincifb --enable-davinciresizer \
38     --enable-v4l2 --disable-aa --enable-wma --disable-faad \
39     --enable-dbus \
40 "
41
42
43 do_configure() {
44         ./bootstrap     
45         gnu-configize
46         libtoolize --force
47         autoreconf --force -i
48         oe_runconf
49         rm config.log
50         sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
51 }
52
53 do_stage() {
54         autotools_stage_all
55 }
56
57 RCONFLICTS_${PN} = "vlc"
58
59 FILES_${PN} += "${bindir}/vlc \
60         ${datadir}/applications \
61         ${datadir}/vlc/ \
62         "