add sliderulez, an advanced RPN pocket calculator for Opie
[vuplus_openembedded] / packages / udev / udev_084.bb
1 DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
2 /dev/, handles hotplug events and loads drivers at boot time. It replaces \
3 the hotplug package and requires a kernel not older than 2.6.12."
4 RPROVIDES = "hotplug"
5
6 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
7            file://noasmlinkage.patch;patch=1 \
8            file://flags.patch;patch=1 \
9            file://udevsynthesize.patch;patch=1 \
10            file://udevsynthesize.sh \
11            file://mount.blacklist"
12            
13 include udev.inc
14
15 INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ."
16
17 PR = "r8"
18
19 FILES_${PN} += "${base_libdir}"
20 UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
21 EXTRA_OEMAKE += "libudevdir=/lib/udev"
22
23 do_install () {
24         install -d ${D}${usrsbindir} \
25                    ${D}${sbindir}
26         oe_runmake 'DESTDIR=${D}' INSTALL=install install
27         install -d ${D}${sysconfdir}/init.d
28         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
29
30         install -d ${D}${sysconfdir}/udev/rules.d/
31
32         install -m 0644 ${WORKDIR}/mount.blacklist     ${D}${sysconfdir}/udev/
33         install -m 0644 ${WORKDIR}/local.rules         ${D}${sysconfdir}/udev/rules.d/local.rules
34         install -m 0644 ${WORKDIR}/permissions.rules   ${D}${sysconfdir}/udev/rules.d/permissions.rules
35         install -m 0644 ${WORKDIR}/udev.rules          ${D}${sysconfdir}/udev/rules.d/udev.rules
36         if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
37                 install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
38         fi
39
40         install -d ${D}${sysconfdir}/udev/scripts/
41
42         install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
43         install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
44
45         install -d ${D}${base_libdir}/udev/
46         install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
47         install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
48 }