merge of '2e1d9e05c5b3d9382dab5905a71f66a069c6915d'
[vuplus_openembedded] / packages / uclibc / uclibc_0.9.29.bb
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!)  uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4 # try removing it
5 #
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
8 #
9 UCLIBC_BASE ?= "0.9.29"
10 PR = "r3"
11
12 require uclibc.inc
13
14 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
15
16 SRC_URI += "file://uClibc.machine file://uClibc.distro"
17 # mmap-unsigned-shift_bugid1303.patch
18 # http://uclibc.org/lists/uclibc-cvs/2007-May/011360.html;patch=1"
19
20 #recent versions uclibc require real kernel headers
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23 #as stated above, uclibc needs real kernel-headers
24 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
25 KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
26
27 SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
28
29 S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
30
31 LEAD_SONAME = "libc.so"
32