merge of '0b604857bbf871639fdb43ee8380222e8ef64bb7'
[vuplus_openembedded] / packages / uclibc / uclibc_0.9.29.bb
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!)  uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4 # try removing it
5 #
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
8 #
9 UCLIBC_BASE ?= "0.9.29"
10 PR = "r11"
11
12 require uclibc.inc
13
14 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
15
16 SRC_URI += "file://uClibc.machine file://uClibc.distro \
17             file://errno_values.h.patch;patch=1 \
18             file://termios.h.patch;patch=1 \
19             file://uClibc-0.9.29-001-fix-mmap.patch;patch=1 \
20             file://uClibc-0.9.29-002-atmel.1.patch;patch=1 \
21             file://uClibc-0.9.29-avr32-fix-sa_onstack.patch;patch=1 \
22             file://uClibc-0.9.29-conditional-sched_affinity.patch;patch=1 \
23             file://uClibc-0.9.29-fix-gethostent_r-failure-retval.patch;patch=1 \
24             file://uClibc-0.9.29-fix-internal_function-definition.patch;patch=1 \
25             file://uClibc-0.9.29-rm-whitespace.patch;patch=1 \
26             file://uClibc-0.9.29-nonposix_bashisms.patch;patch=1 \
27 "
28
29 # mmap-unsigned-shift_bugid1303.patch
30 # http://uclibc.org/lists/uclibc-cvs/2007-May/011360.html;patch=1"
31
32 #recent versions uclibc require real kernel headers
33 PACKAGE_ARCH = "${MACHINE_ARCH}"
34
35 #as stated above, uclibc needs real kernel-headers
36 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
37 KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
38
39 SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
40
41 S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
42
43 LEAD_SONAME = "libc.so"
44