merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / uboot / u-boot_LABEL.2006.06.30.2020.bb
1 DESCRIPTION = "U-boot bootloader"
2 PROVIDES = "virtual/bootloader"
3 SECTION = "bootloader"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6
7 PR = "r2"
8
9 TAG = "${@bb.data.getVar('PV',d,1).replace('.', '_')}"
10
11 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git;tag=${TAG} \
12            file://nohelloworld.patch;patch=1"
13 #           file://config.patch;patch=1"
14
15 SRC_URI_append_navman-icn330 = " http://www.duff.dk/navman/navman-u-boot-2006-30-2020.patch;patch=1"
16
17 S = "${WORKDIR}/git"
18
19 #EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CFLAGS="" CPPFLAGS="" LDFLAGS="""
20 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
21
22 UBOOT_MACHINE ?= "${MACHINE}_config"
23 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.bin"
24
25 PACKAGE_ARCH = "${MACHINE_ARCH}"
26
27 #inherit base
28
29 do_compile () {
30         unset LDFLAGS
31         unset CFLAGS
32         unset CPPFLAGS
33         oe_runmake ${UBOOT_MACHINE}
34         oe_runmake all
35 }
36
37 do_stage() {
38         install -m755 tools/mkimage ${STAGING_BINDIR_NATIVE}
39 }
40
41 do_deploy () {
42         install -d ${DEPLOY_DIR_IMAGE}
43         install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
44 }
45 do_deploy[dirs] = "${S}"
46 addtask deploy before do_build after do_compile