merge of '6347af950ec1a0ff98214a570984c55df668fad7'
[vuplus_openembedded] / packages / u-boot / u-boot_1.2.0.bb
1 require u-boot.inc
2
3 PR = "r3"
4
5 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.2.0.tar.bz2 \
6         "
7 SRC_URI_append_turbostation = "file://qnap.diff;patch=1"
8
9 SRC_URI_append_lsppchg = "file://u-boot-kurobox.patch;patch=1 \
10                           file://u-boot-kurobox-fdt.patch;patch=1 \
11                           file://defconfig_lsppchg"
12
13 SRC_URI_append_lsppchd = "file://u-boot-kurobox.patch;patch=1 \ 
14                           file://u-boot-kurobox-fdt.patch;patch=1 \ 
15                           file://defconfig_lsppchg"
16
17 do_compile_prepend_lsppchg () {
18         cp ${WORKDIR}/defconfig_lsppchg ${S}/include/configs/linkstation.h
19 }
20
21 do_compile_prepend_lsppchd () {
22         cp ${WORKDIR}/defconfig_lsppchd ${S}/include/configs/linkstation.h
23 }
24
25 SRC_URI_append_mpc8315e-rdb = " \
26 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pre.patch;patch=1 \ 
27 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-soc.patch;patch=1 \ 
28 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-PHY.patch;patch=1 \ 
29 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-platform.patch;patch=1 \ 
30 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-controller.patch;patch=1 \ 
31 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-boot.patch;patch=1 \ 
32 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-serdes.patch;patch=1 \ 
33 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pcie.patch;patch=1 \ 
34 http://www.bitshrine.org/gpp/u-boot-fsl-1.3.0-MPC83xx-CW.patch;patch=1 \ 
35 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-silicon-1.1-1.2.patch;patch=1 \ 
36 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-extra-config-for-333-266MHz.patch;patch=1 \ 
37 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-resume-deep-sleep.patch;patch=1 \ 
38 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.patch;patch=1 \ 
39 http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;patch=1 \ 
40 "
41
42 PACKAGE_ARCH = "${MACHINE_ARCH}"