Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / u-boot / u-boot-mkimage-openmoko-native_oe.bb
1 require u-boot-openmoko_git.bb
2
3 inherit native
4
5 PV = "1.2.0+git9912121f7ed804ea58fd62f3f230b5dcfc357d88svn2238"
6 FILE_PR = "r1"
7
8 SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git;tag=9912121f7ed804ea58fd62f3f230b5dcfc357d88 \
9 file://uboot-machtypes.patch;patch=1 \
10 file://ext2load_hex.patch;patch=1 \
11 file://uboot-s3c2410-warnings-fix.patch;patch=1 \
12 file://uboot-strtoul.patch;patch=1 \
13 file://uboot-cramfs_but_no_jffs2.patch;patch=1 \
14 file://nand-read_write_oob.patch;patch=1 \
15 file://uboot-arm920t-gd_in_irq.patch;patch=1 \
16 file://uboot-arm920_s3c2410_irq_demux.patch;patch=1 \
17 file://uboot-s3c2410-nand.patch;patch=1 \
18 file://uboot-cmd_s3c2410.patch;patch=1 \
19 file://uboot-s3c2410-mmc.patch;patch=1 \
20 file://env_nand_oob.patch;patch=1 \
21 file://dynenv-harden.patch;patch=1 \
22 file://uboot-s3c2410_fb.patch;patch=1 \
23 file://uboot-20061030-qt2410.patch;patch=1 \
24 file://uboot-20061030-neo1973.patch;patch=1 \
25 file://uboot-s3c2410-misccr-definitions.patch;patch=1 \
26 file://boot-from-ram-reloc.patch;patch=1 \
27 file://boot-from-ram-and-nand.patch;patch=1 \
28 file://wakeup-reason-nand-only.patch;patch=1 \
29 file://uboot-neo1973-resume.patch;patch=1 \
30 file://nand-dynamic_partitions.patch;patch=1 \
31 file://uboot-s3c2410-norelocate_irqvec_cpy.patch;patch=1 \
32 file://uboot-usbtty-acm.patch;patch=1 \
33 file://uboot-s3c2410_udc.patch;patch=1 \
34 file://bbt-create-optional.patch;patch=1 \
35 file://nand-createbbt.patch;patch=1 \
36 file://dontask.patch;patch=1 \
37 file://nand-badisbad.patch;patch=1 \
38 file://uboot-bbt-quiet.patch;patch=1 \
39 file://raise-limits.patch;patch=1 \
40 file://splashimage-command.patch;patch=1 \
41 file://cmd-unzip.patch;patch=1 \
42 file://enable-splash-bmp.patch;patch=1 \
43 file://preboot-override.patch;patch=1 \
44 file://lowlevel_foo.patch;patch=1 \
45 file://default-env.patch;patch=1 \
46 file://console-ansi.patch;patch=1 \
47 file://boot-menu.patch;patch=1 \
48 file://uboot-dfu.patch;patch=1 \
49 file://uboot-neo1973-defaultenv.patch;patch=1 \
50 file://uboot-nand-markbad-reallybad.patch;patch=1 \
51 file://usbdcore-multiple_configs.patch;patch=1 \
52 file://neo1973-chargefast.patch;patch=1 \
53 file://uboot-s3c2440.patch;patch=1 \
54 file://uboot-smdk2440.patch;patch=1 \
55 file://uboot-hxd8.patch;patch=1 \
56 file://uboot-license.patch;patch=1 \
57 file://uboot-gta02.patch;patch=1 \
58 file://uboot-s3c2443.patch;patch=1 \
59 file://uboot-smdk2443.patch;patch=1 \
60 file://unbusy-i2c.patch;patch=1 \
61 file://makefile-no-dirafter.patch;patch=1 \
62 "
63
64 PROVIDES = ""
65 TARGET_LDFLAGS = ""
66
67 do_quilt() {
68 :
69 }
70
71 do_compile () {
72         chmod +x board/neo1973/gta01/split_by_variant.sh
73         oe_runmake gta01bv3_config
74         oe_runmake clean
75         oe_runmake tools
76 }
77
78 do_stage () {
79         install -m 0755 tools/mkimage ${STAGING_BINDIR}/uboot-mkimage
80         ln -sf ${STAGING_BINDIR}/uboot-mkimage ${STAGING_BINDIR}/mkimage
81 }
82
83 do_deploy () {
84 :
85 }
86