Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / tximage / tximage_0.2.bb
1 DESCRIPTION = "Tx Image Viewer"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://community.zaurus.com/projects/tximage/"
6 FILE_PR = "r2"
7
8 SRC_URI = "http://www.openzaurus.org/mirror/tximage-${PV}.tar.gz \
9            file://gcc3.patch;patch=1 \
10            file://gcc4.patch;patch=1"
11
12 inherit palmtop
13
14 do_install() {
15         install -d ${D}${palmtopdir}/apps/Applications \
16                    ${D}${palmtopdir}/pics \
17                    ${D}${palmtopdir}/bin
18         install -D -m 755 tximage ${D}${palmtopdir}/bin/tximage
19         install -D -m 644 imageviewer.desktop ${D}${palmtopdir}/apps/Applications/tximage.desktop
20         cp -pPR tximage.png ${D}${palmtopdir}/pics/
21 }