tslib: fix HOMEPAGE
[vuplus_openembedded] / packages / tslib / tslib_1.0.bb
1 DESCRIPTION = "tslib is a plugin-based flexible touchscreen access library."
2 HOMEPAGE = "http://tslib.berlios.de/"
3 AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
4 SECTION = "base"
5 LICENSE = "LGPL"
6
7 PR = "r4"
8
9 SRC_URI = "http://download.berlios.de/tslib/tslib-1.0.tar.bz2 \
10            file://ts.conf \
11            file://ts.conf-h3600-2.4 \
12            file://ts.conf-simpad-2.4 \
13            file://ts.conf-corgi-2.4 \
14            file://ts.conf-collie-2.4 \
15            file://tslib.sh"
16 SRC_URI_append_mnci += " file://devfs.patch;patch=1"
17 SRC_URI_append_mnci += " file://event1.patch;patch=1"
18
19 inherit autotools pkgconfig
20
21 EXTRA_OECONF        = "--enable-shared"
22 EXTRA_OECONF_mnci   = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
23
24 do_stage() {
25         autotools_stage_all
26 }
27
28 do_install_prepend() {
29         install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
30 }
31
32 do_install_append() {
33         install -d ${D}${sysconfdir}/profile.d/
34         install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
35         case ${MACHINE} in
36         a780 | e680 | h3600 | h3900 | h5000 | h1940 | h6300 | h2200 | ipaq-pxa270 | hx4700 | hx2000 | blueangel | h4000)
37                 install -d ${D}${datadir}/tslib
38                 install -m 0644 ${WORKDIR}/ts.conf-h3600-2.4 ${D}${datadir}/tslib/
39                 ;;
40         c7x0 | spitz | akita | tosa )
41                 install -d ${D}${datadir}/tslib
42                 install -m 0644 ${WORKDIR}/ts.conf-corgi-2.4 ${D}${datadir}/tslib/
43                 ;;
44         collie | poodle )
45                 install -d ${D}${datadir}/tslib
46                 install -m 0644 ${WORKDIR}/ts.conf-collie-2.4 ${D}${datadir}/tslib/
47                 ;;
48
49         simpad )
50                 install -d ${D}${datadir}/tslib
51                 install -m 0644 ${WORKDIR}/ts.conf-simpad-2.4 ${D}${datadir}/tslib/
52                 ;;
53         *)
54                 ;;
55         esac
56 }
57
58 SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
59
60 # People should consider using udev's /dev/input/touchscreen0 symlink 
61 # instead of detect-stylus
62 RDEPENDS_tslib-conf_h1940 = "detect-stylus"
63 RDEPENDS_tslib-conf_h3600 = "detect-stylus"
64 RDEPENDS_tslib-conf_h3900 = "detect-stylus"
65 RDEPENDS_tslib-conf_blueangel = "detect-stylus"
66 RPROVIDES_tslib-conf = "libts-0.0-conf"
67
68 PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
69 PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
70
71 PACKAGES =+ "tslib-conf libts-dev tslib-tests tslib-calibrate"
72 DEBIAN_NOAUTONAME_tslib-conf = "1"
73 DEBIAN_NOAUTONAME_tslib-tests = "1"
74 DEBIAN_NOAUTONAME_tslib-calibrate = "1"
75
76 RDEPENDS_${PN} = "tslib-conf"
77
78
79 FILES_${PN}-dbg += "${libdir}/ts/.debug*"
80 FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
81 FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
82 FILES_libts-dev = "${FILES_tslib-dev}"
83 FILES_tslib-calibrate += "${bindir}/ts_calibrate"
84 FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"