Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / thttpd / thttpd_2.25b.bb
1 DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
2 LICENSE = "BSD"
3 HOMEPAGE = "http://www.acme.com/software/thttpd/"
4 PR ="r6"
5
6 SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
7            file://install.patch;patch=1 \
8            file://acinclude.m4 \
9            file://init \
10            file://htpasswd_shared.diff;patch=1"
11 S = "${WORKDIR}/thttpd-${PV}"
12
13 INITSCRIPT_NAME = "thttpd"
14 INITSCRIPT_PARAMS = "defaults"
15
16 inherit autotools update-rc.d
17
18 EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'"
19 FILES_${PN}-dbg_append = " ${servicedir}/www/cgi-bin/.debug"
20 FILES_${PN}_append = " ${servicedir}"
21
22 do_configure () {
23         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
24         autotools_do_configure
25 }
26
27 do_install_append () {
28         install -d "${D}${sysconfdir}/init.d"
29         cat ${WORKDIR}/init | sed -e 's,@@SRVDIR,${servicedir}/www,g' > ${WORKDIR}/thttpd
30         install -c -m 755 ${WORKDIR}/thttpd ${D}${sysconfdir}/init.d/thttpd
31 }
32