Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / tcltk / tk_8.4.11.bb
1 DESCRIPTION = "Tool Command Language ToolKit Extension"
2 LICENSE = "tcl"
3 SECTION = "devel/tcltk"
4 HOMEPAGE = "http://tcl.sourceforge.net"
5 DEPENDS = "tcl virtual/libx11 libxt"
6 RDEPENDS = "tcl"
7 PR = "r5"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tk${PV}-src.tar.gz \
10            file://disable-xim.patch;patch=1;pnum=0 \
11            file://tk-add-soname.patch;patch=1 \
12            file://fix-configure.patch;patch=1;pnum=2"
13
14 S = "${WORKDIR}/tk${PV}/unix"
15
16 inherit autotools
17
18 EXTRA_OECONF = "--enable-threads --with-tcl=${STAGING_BINDIR_CROSS} \
19                 --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
20
21 do_configure() {
22         gnu-configize
23         oe_runconf
24 }
25
26 do_stage() {
27         oe_libinstall -a libtkstub8.4 ${STAGING_LIBDIR}
28         oe_libinstall -so libtk8.4 ${STAGING_LIBDIR}
29         sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tkConfig.sh
30         install -m 0755 tkConfig.sh ${STAGING_BINDIR_CROSS}
31         cd ..
32         #for dir in compat generic unix
33         #do
34         #       install -d ${STAGING_INCDIR}/tk${PV}/$dir
35         #install -m 0644 $dir/*.h ${STAGING_INCDIR}/tk${PV}/$dir/
36         #done
37         install -m 0644 generic/tk.h ${STAGING_INCDIR}
38         install -m 0644 generic/tkDecls.h ${STAGING_INCDIR}
39         install -m 0644 generic/tkPlatDecls.h ${STAGING_INCDIR}
40
41 }
42
43 do_install() {
44         autotools_do_install
45         oe_libinstall -so libtk8.4 ${D}${libdir}
46         ln -sf ./wish8.4 ${D}${bindir}/wish
47 }
48
49 FILES_${PN} += "${libdir}/tk8.4 ${libdir}/libtk8.4.so"