merge of '178eac00dc5aa8338d42e8e203633bec7817bbf6'
[vuplus_openembedded] / packages / tasks / task-slugos.bb
1 # This describes a generic SlugOS image, even though the bb file is
2 # called 'slugos-image.bb' the distro specific configuration is
3 # done in conf/distro/${DISTRO}.conf (which should always include
4 # conf/distro/slugos.conf to get the standard settings).
5 #
6 DESCRIPTION = "Task packages for the SlugOS distribution"
7 HOMEPAGE = "http://www.nslu2-linux.org"
8 LICENSE = "MIT"
9 PR = "r18"
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 ALLOW_EMPTY = "1"
12
13 #----------------------------------------------------------------------------------
14 # FIRMWARE CONFIGURATION
15 #----------------------------------------------------------------------------------
16 # EXTRA PACKAGES
17 # --------------
18 # The standard firmware contents and additional packages built as requirements
19 # of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.
20 SLUGOS_STANDARD_RDEPENDS = ""
21 SLUGOS_STANDARD_RRECOMMENDS = ""
22
23 # diff, cpio and find are required for turnup and ipkg.
24 SLUGOS_STANDARD_RRECOMMENDS += "\
25 diffutils \
26 cpio \
27 findutils \
28 "
29
30 # These lines add support for formatting ext2 and ext3 file systems
31 # on a hard disk attached to the NSLU2.  ext3 is the standard Linux
32 # file system.
33 SLUGOS_STANDARD_RRECOMMENDS += "\
34 e2fsprogs-mke2fs \
35 e2fsprogs-fsck \
36 e2fsprogs-e2fsck \
37 e2fsprogs-badblocks \
38 e2fsprogs-blkid \
39 "
40
41 # These lines add support for an X/Y/ZModem package called lrzsz
42 # (this is of use for people with modified NSLU2 hardware which
43 # supports a serial port.)
44 SLUGOS_STANDARD_RRECOMMENDS += "lrzsz"
45
46 # Filesystem selection.  Adding entries here adds the module to the
47 # image.  The module must be built as part of nslu2-kernel (i.e. it
48 # must be specified as a module in the defconfig file).  The NLS
49 # support charset modules must be given explicitly and must match
50 # the codepage/iocharset and NLS handling for the file systems which
51 # require them.  The installed lanugage set is minimal but sufficient
52 # for any file system (since it uses utf8).  See
53 # http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
54 # for more information on the language behaviour of the DOS file
55 # systems.
56 #
57 # KERNEL LEVEL FILE SYSTEM SUPPORT
58 # --------------------------------
59 # NOTE: removing kernel-module-nfs from this list will prevent NFS
60 # boot (however you can do a simple flash file system boot - no
61 # attached disk - and install the nfs modules from ssh.)
62 # The altboot mechanism requires kernel-module-loop.
63 SLUGOS_STANDARD_RRECOMMENDS += "\
64 kernel-module-ext2 \
65 kernel-module-jbd \
66 kernel-module-ext3 \
67 kernel-module-vfat \
68 kernel-module-nls-cp437 \
69 kernel-module-nls-utf8 \
70 kernel-module-nfs \
71 "
72
73 # Add daemon required for HW RNG support
74 SLUGOS_RNG_TOOLS_PACKAGE = "rng-tools"
75 SLUGOS_RNG_TOOLS_PACKAGE_linux-uclibc = ""
76 SLUGOS_STANDARD_RRECOMMENDS += "\
77 ${SLUGOS_RNG_TOOLS_PACKAGE} \
78 "
79
80 # Add modules required for usb support
81 SLUGOS_STANDARD_RRECOMMENDS += "\
82 kernel-module-ehci-hcd \
83 kernel-module-ohci-hcd \
84 kernel-module-uhci-hcd \
85 "
86
87 # Add modules required for IDE support
88 SLUGOS_STANDARD_RRECOMMENDS += "\
89 kernel-module-libata \
90 kernel-module-pata-artop \
91 "
92
93 # Add modules required for Network support
94 SLUGOS_STANDARD_RRECOMMENDS += "\
95 kernel-module-mii \
96 kernel-module-ixp4xx-mac \
97 kernel-module-ixp4xx-qmgr \
98 kernel-module-via-velocity \
99 "
100
101 # Other candidate packages that have been considered and
102 # are intentionally excluded from the base flash image.
103 #
104 # portmap \
105 # kexec-tools \
106 # kernel-module-isofs \
107 # kernel-module-udf \
108 # kernel-module-loop \
109 # kernel-module-netconsole \
110 # wpa-supplicant \
111 # zd1211-firmware kernel-module-zd1211rw \
112 # madwifi-ng-modules madwifi-ng-tools wireless-tools \
113
114 DISTRO_EXTRA_DEPENDS ?= ""
115 DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
116
117 DISTRO_EXTRA_RDEPENDS ?= ""
118 RDEPENDS += "\
119         kernel ixp4xx-npe \
120         base-files base-passwd netbase \
121         busybox initscripts-slugos slugos-init \
122         update-modules sysvinit tinylogin udev \
123         module-init-tools modutils-initscripts \
124         ipkg-collateral ipkg ipkg-link \
125         libgcc \
126         beep \
127         util-linux-mount \
128         util-linux-umount \
129         util-linux-swaponoff \
130         util-linux-losetup \
131         ${SLUGOS_STANDARD_RDEPENDS} \
132         ${DISTRO_EXTRA_RDEPENDS}"
133
134 DISTRO_EXTRA_RRECOMMENDS ?= ""
135 RRECOMMENDS += "\
136         openssh \
137         ${SLUGOS_STANDARD_RRECOMMENDS} \
138         ${DISTRO_EXTRA_RRECOMMENDS}"