Bluez: removed outdated stuff so multithreaded bitbake doesn't break apps depending...
[vuplus_openembedded] / packages / syslinux / syslinux-native_2.11.bb
1 # syslinux-native OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION="A multi-purpose linux bootloader"
6 HOMEPAGE="http://syslinux.zytor.com/"
7 LICENSE="GPL"
8
9 PR="r1"
10
11 SRC_URI="http://www.kernel.org/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2 \
12 file://edx_assume_zero.patch;patch=1"
13
14 S="${WORKDIR}/syslinux-${PV}"
15
16 # If you really want to run syslinux, you need mtools.  We just want the 
17 # ldlinux.* stuff for now, so skip mtools-native
18
19 DEPENDS="nasm-native"
20
21 inherit native
22
23 do_compile() {
24         oe_runmake syslinux
25 }
26
27 do_stage() {
28         install -d ${STAGING_BINDIR}
29         install -m 755 ${S}/syslinux ${STAGING_BINDIR}
30
31         # When building media, the syslinux binary isn't nearly as useful
32         # as the DOS data files, so we copy those into a special location
33         # for usage during a image build stage
34
35         install -d ${STAGING_DATADIR}/syslinux
36         install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
37         install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
38 }