merge of '7393275c6ccce67cadeb49d4afb3459e56edf8a9'
[vuplus_openembedded] / packages / subversion / subversion_1.4.5.bb
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util neon"
4 RDEPENDS = "neon"
5 LICENSE = "Apache BSD"
6 HOMEPAGE = "http://subversion.tigris.org"
7
8 PR = "r0"
9
10 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11            file://disable-revision-install.patch;patch=1 \
12            file://neon-detection.patch;patch=1"
13
14 EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
15                 --without-berkeley-db --without-apxs --without-apache \
16                 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
17                 --with-apr-util=${STAGING_BINDIR_CROSS}"
18
19
20 inherit autotools
21
22 export LDFLAGS += " -L${STAGING_LIBDIR} "
23
24 acpaths = "-I build/ -I build/ac-macros/"
25
26 do_stage() {
27         autotools_stage_all
28 }