merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / subversion / subversion_1.4.0.bb
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util-0.9.12 neon"
4 LICENSE = "Apache/BSD"
5 HOMEPAGE = "http://subversion.tigris.org"
6 PR = "r0"
7
8 DEFAULT_PREFERENCE = "-1"
9
10 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11            file://disable-revision-install.patch;patch=1"
12
13 EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${BUILD_SYS} \
14                 --without-berkeley-db --without-apxs --without-apache \
15                 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
16                 --with-apr-util=${STAGING_BINDIR_CROSS}"
17
18 inherit autotools
19
20 do_configure() {
21         oe_runconf
22 }