merge of '7393275c6ccce67cadeb49d4afb3459e56edf8a9'
[vuplus_openembedded] / packages / speech-dispatcher / speech-dispatcher_0.6.6.bb
1 DESCRIPTION = "Speech Dispatcher is a high-level device independent layer \
2 for speech synthesis through a simple, stable and well documented interface."
3 HOMEPAGE = "http://www.freebsoft.org/speechd/"
4 LICENSE = "GPLv2"
5 DEPENDS = "espeak flite pulseaudio libdotconf glib-2.0"
6 RPROVIDES_${PN} += "speechd"
7
8 PR = "r0"
9
10 inherit autotools update-rc.d
11
12 SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
13            file://speech-dispatcher.init \
14            file://srcMakefile.am.patch;patch=1 \
15            file://configure_fix.patch;patch=1 \
16            file://configSpeechd.conf.in_00.patch;patch=1"
17
18 LEAD_SONAME = "libspeechd.so"
19 EXTRA_OECONF = " --with-espeak --with-flite --without-ibmtts --without-nas --with-alsa --with-pulse "
20
21 INITSCRIPT_NAME = "speech-dispatcher"
22 INITSCRIPT_PARAMS = "defaults 45"
23
24 do_install() {
25         install -d ${D}${bindir}
26         install -d ${D}${includedir}
27         install -d ${D}${libdir}/${PN}-modules
28         install -d ${D}${sysconfdir}    
29         install -d ${D}${sysconfdir}/init.d
30         install -d ${D}${sysconfdir}/speech-dispatcher
31         install -d ${D}${sysconfdir}/speech-dispatcher/modules
32
33         oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
34         oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
35         
36         install -m 0644 ${S}/src/c/api/libspeechd.h    ${D}${includedir}
37         install -m 0755 ${S}/src/c/clients/say/.libs/spd-say ${D}${bindir}
38         install -m 0755 ${S}/src/server/.libs/speech-dispatcher  ${D}${bindir}
39         install -m 0755 ${S}/src/modules/.libs/sd_*   ${D}${libdir}/${PN}-modules/
40         
41         install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}/speech-dispatcher
42         install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/speech-dispatcher/modules
43         install -m 0755 ${WORKDIR}/speech-dispatcher.init ${D}${sysconfdir}/init.d/speech-dispatcher
44 }
45
46 do_stage() {
47         install -m 0644 ${S}/src/c/api/libspeechd.h ${STAGING_INCDIR}
48         oe_libinstall -so -C src/c/api libspeechd ${STAGING_LIBDIR}
49 }
50
51 PACKAGES =+ "libspeechd-dbg libspeechd libspeechd-dev"
52
53 FILES_${PN} += "${libdir}/${PN}-modules/*" 
54 FILES_${PN}-dbg += "${libdir}/${PN}-modules/.debug" 
55 FILES_libspeechd += "${libdir}/libspeechd.so.*"
56 FILES_libspeechd-dev += "${libdir}/libspeechd* ${includedir}"
57 FILES_libspeechd-dbg += "${libdir}/.debug/libspeechd*"