Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / snes9x / snes9x_1.43-WIP1.bb
1 SECTION = "x11/games"
2 FILE_PR = "r3"
3 LICENSE = "snes9x"
4 DEPENDS = "libxxf86dga libxxf86vm"
5 DEPENDS_append_i686 = " nasm-native"
6 RDEPENDS_epia = "kernel-module-joydev"
7
8 SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
9         file://makefile.patch;patch=1;pnum=2 \
10         file://private.patch;patch=1;pnum=0 \
11         file://64bit.patch;patch=1"
12
13 S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
14
15 inherit autotools
16
17 export OECFLAGS="${CFLAGS}"
18 export OELDFLAGS="${LDFLAGS}"
19
20 do_configure() {
21         oe_runconf
22 }
23
24 do_install() {
25         install -d ${D}${bindir}
26         install snes9x ${D}${bindir}
27 }