Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / sharp-binary-only / sharp-sdmmc-support.bb
1 DESCRIPTION = "Driver for the SHARP Zaurus SD/MMC Slot for linux ${PV}"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 LICENSE = "CLOSED"
5 RDEPENDS = "kernel (${PV})"
6 FILE_PR = "r23"
7 PACKAGE_ARCH = "${MACHINE}"
8
9 COMPATIBLE_MACHINE = '(collie|poodle|tosa)'
10
11 KERNEL2418 = "2.4.18-rmk7-pxa3-embedix"
12 KERNEL2420 = "2.4.20"
13
14 PV_collie = "${KERNEL2418}"
15 PV_poodle = "${KERNEL2418}"
16 PV_tosa   = "${KERNEL2418}"
17 PV_akita  = "${KERNEL2420}"
18 PV_borzoi = "${KERNEL2420}"
19 PV_spitz  = "${KERNEL2420}"
20
21 SRC_URI = "http://openzaurus.sf.net/mirror/sd-modules-2.4.18-rmk7-pxa3-embedix-r4.tar.bz2 \
22            file://sd \
23            file://sdmgr \
24            file://sdcontrol"
25
26 S = "${WORKDIR}"
27
28 inherit module-base update-rc.d
29
30 INITSCRIPT_NAME = "sd"
31 INITSCRIPT_PARAMS = "start 39 S . stop 96 0 1 6 ."
32
33 do_install() {
34         install -d ${D}${sysconfdir}/init.d \
35                    ${D}${sysconfdir}/default \
36                    ${D}${base_sbindir} \
37                    ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
38
39         install -m 0755 ${WORKDIR}/sdmgr ${D}${base_sbindir}/
40         install -m 0755 ${WORKDIR}/sdcontrol ${D}${sysconfdir}
41         install -m 0755 ${WORKDIR}/sd ${D}${sysconfdir}/init.d/
42         install -m 0644 ${MACHINE}/sharp_mmcsd_m.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
43         echo "MODULE_FILE='${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/sharp_mmcsd_m.o'" > ${D}${sysconfdir}/default/sharp_sdmmc
44 }
45
46 FILES_${PN} = "/"