Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / sharp-binary-only / sharp-compat-libs_0.5.bb
1 DESCRIPTION = "Allows applications compiled with 2.95 to run on a 3.x compiled \
2 system by providing 2.95 libraries. To run compatible programs, use the Compat \
3 Library program in the Settings menu to make them use these libraries."
4 SECTION = "opie/settings"
5 PRIORITY = "optional"
6 DEPENDS = "opie-sh"
7 RDEPENDS = "opie-sh"
8 RPROVIDES = "oz-compat"
9 RCONFLICTS = "oz-compat"
10 LICENSE = "GPL"
11 FILE_PR = "r2"
12
13 EXCLUDE_FROM_SHLIBS = "1"
14 COMPATIBLE_HOST = "arm.*-linux"
15
16 SRC_URI = "http://openzaurus.org/mirror/oz-compat_0.5.tar.gz \
17            file://hentges.patch;patch=1 \
18            file://qt2310.patch;patch=1"
19
20 S = "${WORKDIR}/oz-compat-0.5"
21
22 inherit update-rc.d
23
24 INITSCRIPT_NAME = "quickexec"
25 INITSCRIPT_PARAMS = "defaults 10"
26
27 do_install() {
28         install -d ${D}${palmtopdir}/apps/Settings
29         install -d ${D}${palmtopdir}/bin/
30         install -d ${D}${palmtopdir}/etc/
31         install -d ${D}${palmtopdir}/pics/
32
33         install -d ${D}/opt/QtPalmtop.compat/bin
34         install -d ${D}/opt/QtPalmtop.compat/binlib
35         install -d ${D}/opt/QtPalmtop.compat/lib
36
37         install -d ${D}${sysconfdir}/init.d
38
39         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/apps/Settings/makecompat.desktop ${D}${palmtopdir}/apps/Settings
40         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/etc/quickexec.libs ${D}${palmtopdir}/etc/quickexec.libs
41         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/pics/libraries.png ${D}${palmtopdir}/pics/libraries.png
42
43         install -m 0755 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop.compat/bin/* ${D}/opt/QtPalmtop.compat/bin
44         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop.compat/lib/* ${D}/opt/QtPalmtop.compat/lib
45
46         install -m 0755 ${WORKDIR}/oz-compat-0.5/etc/init.d/quickexec ${D}${sysconfdir}/init.d
47
48         cd ${D}${palmtopdir}/bin
49         for file in chkhinge makecompat qeserver quickexec runcompat
50         do
51                 ln -s /opt/QtPalmtop.compat/bin/$file
52         done
53
54         cd ${D}/opt/QtPalmtop.compat/lib
55         ln -s libqpe.so.1.5.0 libqpe.so.1.5
56         ln -s libqpe.so.1.5.0 libqpe.so.1
57         ln -s libqpe.so.1.5.0 libqpe.so
58
59         ln -s libqte.so.2.3.7 libqte.so.2.3.2
60         ln -s libqte.so.2.3.7 libqte.so.2.3
61         ln -s libqte.so.2.3.7 libqte.so.2
62         ln -s libqte.so.2.3.7 libqte.so
63
64
65 }
66
67 pkg_postinst() {
68 test -n "$D" && exit 1
69
70 # needed for update-rc.d
71 test -e /media/card/etc/init.d/quickexec && ln -s /media/card/etc/init.d/quickexec /etc/init.d/quickexec
72 test -e /media/cf/etc/init.d/quickexec && ln -s /media/cf/etc/init.d/quickexec /etc/init.d/quickexec
73 test -e /media/ram/etc/init.d/quickexec && ln -s /media/ram/etc/init.d/quickexec /etc/init.d/quickexec
74 }
75
76 pkg_postrm() {
77         test -e /etc/init.d/quickexec && rm /etc/init.d/quickexec
78 }
79
80 FILES_${PN} += "/opt /etc"
81 LEAD_SONAME = "libqte.so.*"