merge of '764fab90ce78632168aaaa389123bbc7beacc0af'
[vuplus_openembedded] / packages / samba / samba_3.0.23c.bb
1 PR = "r0"
2
3 SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
4            file://configure.patch;patch=1 \
5            file://cifs.patch;patch=1 \
6            file://config-lfs.patch;patch=1 \
7            file://init \
8            file://quota.patch;patch=1;pnum=0 \
9            "
10 S = "${WORKDIR}/${P}/source"
11
12 include samba.inc
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "samba"
16 # No dependencies, goes in at level 20 (NOTE: take care with the
17 # level, later levels put the shutdown later too - see the links
18 # in rc6.d, the shutdown must precede network shutdown).
19 INITSCRIPT_PARAMS = "defaults"
20 CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
21
22 # The file system settings --foodir=dirfoo and overridden unconditionally
23 # in the samba config by --with-foodir=dirfoo - even if the --with is not
24 # specified!  Fix that here.  Set the privatedir to /etc/samba/private.
25 EXTRA_OECONF += "\
26         samba_cv_struct_timespec=yes \
27         --with-configdir=${sysconfdir}/samba \
28         --with-privatedir=${sysconfdir}/samba/private \
29         --with-lockdir=${localstatedir}/lock \
30         --with-piddir=${localstatedir}/run \
31         --with-logfilebase=${localstatedir}/log \
32         --with-libdir=${libdir} \
33         --with-mandir=${mandir} \
34         --with-swatdir=${datadir}/swat \
35         "
36
37 do_install_append() {
38         install -d "${D}${localstatedir}/log"
39         rm -f ${D}/sbin/mount.smbfs
40         ln -sf smbmount ${D}${sbindir}/mount.smbfs
41         install -d "${D}${sysconfdir}/init.d"
42         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
43         install -d "${D}${sysconfdir}/samba"
44         install -c -m 644 ../examples/smb.conf.default ${D}${sysconfdir}/samba/smb.conf
45 }
46
47 PACKAGES =+ "swat"
48
49 FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
50 FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat ${libdir}/auth/*.so"
51 #
52 # bug fix for samba.inc:
53 FILES_cifs-doc = "${mandir}/man8/mount.cifs.8"