merge of '971d18af52c7881e09c9f5ffa43d9bf33216ce83'
[vuplus_openembedded] / packages / samba / samba_3.0.23c.bb
1 require samba.inc
2 inherit update-rc.d
3
4 SRC_URI += "file://config-lfs.patch;patch=1 \
5            file://init \
6            file://quota.patch;patch=1;pnum=0 \
7            "
8
9 INITSCRIPT_NAME = "samba"
10 # No dependencies, goes in at level 20 (NOTE: take care with the
11 # level, later levels put the shutdown later too - see the links
12 # in rc6.d, the shutdown must precede network shutdown).
13 INITSCRIPT_PARAMS = "defaults"
14 CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
15
16 # The file system settings --foodir=dirfoo and overridden unconditionally
17 # in the samba config by --with-foodir=dirfoo - even if the --with is not
18 # specified!  Fix that here.  Set the privatedir to /etc/samba/private.
19 EXTRA_OECONF += "\
20         samba_cv_struct_timespec=yes \
21         --with-configdir=${sysconfdir}/samba \
22         --with-privatedir=${sysconfdir}/samba/private \
23         --with-lockdir=${localstatedir}/lock \
24         --with-piddir=${localstatedir}/run \
25         --with-logfilebase=${localstatedir}/log \
26         --with-libdir=${libdir} \
27         --with-mandir=${mandir} \
28         --with-swatdir=${datadir}/swat \
29         "
30
31 do_install_append() {
32         install -d "${D}${localstatedir}/log"
33         rm -f ${D}/sbin/mount.smbfs
34         ln -sf smbmount ${D}${sbindir}/mount.smbfs
35         install -d "${D}${sysconfdir}/init.d"
36         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
37         install -d "${D}${sysconfdir}/samba"
38         install -c -m 644 ../examples/smb.conf.default ${D}${sysconfdir}/samba/smb.conf
39 }
40
41 PACKAGES =+ "swat"
42
43 FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
44 FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat ${libdir}/auth/*.so"
45 #
46 # bug fix for samba.inc:
47 FILES_cifs-doc = "${mandir}/man8/mount.cifs.8"