merge of 2d6d863c36fd1d9d7ab0dba3d700e0f1ccf122be
[vuplus_openembedded] / packages / samba / samba-essential_3.0.20.bb
1 PR = "r1"
2
3 SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
4            file://configure.patch;patch=1 \
5            file://cifs.patch;patch=1 \
6            file://config-lfs.patch;patch=1 \
7            file://init \
8            file://quota.patch;patch=1;pnum=0 \
9            file://smb-essential.conf \
10            file://Managing-Samba.txt"
11            
12 S := ${WORKDIR}/samba-${PV}/source
13
14 RCONFILCTS = samba
15
16 include samba-essential.inc
17 inherit update-rc.d
18
19 INITSCRIPT_NAME = "samba"
20 # No dependencies, goes in at level 20 (NOTE: take care with the
21 # level, later levels put the shutdown later too - see the links
22 # in rc6.d, the shutdown must precede network shutdown).
23 INITSCRIPT_PARAMS = "defaults"
24 CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
25
26 # The file system settings --foodir=dirfoo and overridden unconditionally
27 # in the samba config by --with-foodir=dirfoo - even if the --with is not
28 # specified!  Fix that here.  Set the privatedir to /etc/samba/private.
29 EXTRA_OECONF += "\
30         --with-configdir=${sysconfdir}/samba \
31         --with-privatedir=${sysconfdir}/samba/private \
32         --with-lockdir=${localstatedir}/lock \
33         --with-piddir=${localstatedir}/run \
34         --with-logfilebase=${localstatedir}/log \
35         --with-libdir=${libdir} \
36         --with-mandir=${mandir} \
37         "
38
39 do_install_append() {
40         install -d "${D}${localstatedir}/log"
41         rm -f ${D}/sbin/mount.smbfs
42         rmdir ${D}/sbin
43         install -d "${D}${sysconfdir}/init.d"
44         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
45         
46         install -d "${D}${sysconfdir}/samba"    
47         install -d "${D}/usr/share/samba/help"  
48         
49         install ${WORKDIR}/smb-essential.conf "${D}${sysconfdir}/samba/smb.conf"
50         install ${WORKDIR}/Managing-Samba.txt  ${D}/usr/share/samba/help
51         
52 }
53
54 FILES_${PN} = "${bindir}/smbpasswd \           
55                ${sbindir}/nmbd \
56                ${sbindir}/smbd \
57                ${libdir}/charset \
58                ${libdir}/vfs \
59                ${libdir}/*.dat \
60                /usr/share/samba \
61                /etc"