Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / rtaudio / librtaudio_3.0.1.bb
1 DESCRIPTION = "RtAudio is a set of C++ classes which provide a common API \
2 for realtime audio input/output across Linux (native ALSA, JACK, and OSS), \
3 Macintosh OS X, SGI, and Windows (DirectSound and ASIO) operating systems."
4 SECTION = "libs"
5 LICENSE = "rtaudio"
6 HOMEPAGE = "http://www.music.mcgill.ca/~gary/rtaudio"
7 DEPENDS = "alsa-lib"
8 FILE_PR = "r0"
9
10 SRC_URI = "http://music.mcgill.ca/~gary/rtaudio/release/rtaudio-${PV}.tar.gz"
11 S = "${WORKDIR}/rtaudio-${PV}"
12
13 inherit qmake qt3x11
14
15 do_configure_prepend() {
16         qmake -project -t lib -nopwd *.cpp *.h
17 }
18
19 EXTRA_QMAKEVARS_POST = "CONFIG=console CONFIG+=thread DEFINES+=__LINUX_OSS__ DEFINES+=__LINUX_ALSA__ LIBS+=-lasound"
20
21 do_stage() {
22         install -m 0644 *.h ${STAGING_INCDIR}
23         oe_libinstall -so librtaudio-3.0.1 ${STAGING_LIBDIR}
24 }
25
26 do_install() {
27         oe_libinstall -so librtaudio-3.0.1 ${D}${libdir}
28 }