Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / rott / rott_1.0.bb
1 DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
2 HOMEPAGE = "http://www.icculus.org/root"
3 LICENSE = "GPL"
4 PR = "r2"
5
6 APPIMAGE = "${WORKDIR}/rott.jpg"
7
8 SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
9            file://gcc4.patch;patch=1;pnum=2 \
10            file://rott.jpg"
11 S = "${WORKDIR}/rott-${PV}/rott"
12
13 CFLAGS += "-DPLATFORM_UNIX"
14 EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
15
16 inherit sdl
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 0755 rott ${D}${bindir}
21 }