Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / python / python24-native_2.4.0.bb
1 DESCRIPTION = "Python Programming Language"
2 HOMEPAGE = "http://www.python.org"
3 LICENSE = "PSF"
4 SECTION = "devel/python"
5 PRIORITY = "optional"
6 DEPENDS = ""
7 PR = "r2"
8
9 EXCLUDE_FROM_WORLD = "1"
10
11 SRC_URI = "http://www.python.org/ftp/python/2.4/Python-2.4.tar.bz2 \
12            file://bindir-libdir.patch;patch=1 \
13            file://cross-distutils.patch;patch=1 \
14            file://dont-modify-shebang-line.patch;patch=1"
15 S = "${WORKDIR}/Python-2.4"
16
17 inherit autotools native
18
19 prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
20 exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
21
22 EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
23                 --without-cxx --with-signal-module --with-wctype-functions"
24 EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
25
26 do_configure() {
27         # the autofoo stuff is too old to allow regenerating
28         oe_runconf
29 }
30
31 do_stage_append() {
32         # install pgen for later usage with non-native builds
33         install Parser/pgen ${STAGING_BINDIR_NATIVE}/
34 }
35