Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / python / python-sword_1.5.10.bb
1 DESCRIPTION = "Python bindings for the sword library"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 RDEPENDS = "python-core sword"
6 DEPENDS = "sword-${PV} swig-native"
7 SRCNAME = "sword"
8 FILE_PR = "r0"
9
10 SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
11
12 S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
13
14 EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR_HOST}${layout_exec_prefix}"
15
16 inherit distutils autotools
17
18 PARALLEL_MAKE = ""
19
20 do_configure_prepend() {
21         touch ltmain.sh
22         ./autogen.sh
23 }
24
25 do_compile() {
26         oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
27 }
28
29 do_install() {
30         cd ${S}/python
31         distutils_do_install
32 }