merge of '6347af950ec1a0ff98214a570984c55df668fad7'
[vuplus_openembedded] / packages / python / python-setuptools_0.6c8.bb
1 DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2 HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3 SECTION = "devel/python"
4 PRIORITY = "optional"
5 LICENSE = "MIT-like"
6 RDEPENDS = "python-distutils python-compression"
7 SRCNAME = "setuptools"
8 PR = "ml2"
9
10 SRC_URI = "\
11   http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
12   file://fix-log-usage.patch;patch=1 \
13 "
14 S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16 inherit distutils
17
18 do_install_prepend() {
19     install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
20 }