Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / python / python-pygtk_2.8.6.bb
1 DESCRIPTION = "Python GTK+ Bindings"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 # needs gtk+ 2.8.x
5 DEPENDS = "gtk+-2.8.16 libglade"
6 RDEPENDS = "python-shell"
7 SRCNAME = "pygtk"
8 LICENSE = "LGPL"
9 PR = "r1"
10
11 MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
12 SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
13            file://acinclude.m4"
14 S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16 inherit autotools pkgconfig distutils-base
17
18 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
19
20 do_configure_prepend() {
21         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
22 }
23
24 do_stage() {
25         autotools_stage_includes
26         install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
27 }