merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / python / python-pygtk2_2.8.6.bb
1 DESCRIPTION = "Python GTK+ Bindings"
2 SECTION = "devel/python"
3 # needs gtk+-2.8.x
4 DEPENDS = "gtk+ libglade"
5 RDEPENDS = "python-shell"
6 SRCNAME = "pygtk"
7 LICENSE = "LGPL"
8 PR = "ml0"
9
10 SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.8/${SRCNAME}-${PV}.tar.bz2 \
11            file://acinclude.m4"
12 S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14 inherit autotools pkgconfig distutils-base
15
16 do_configure_prepend() {
17         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
18 }
19
20 do_stage() {
21         autotools_stage_includes
22         install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
23 }