Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / pth / pth_2.0.2.bb
1 DESCRIPTION = "GNU Portable Threads"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL FDL"
5 FILE_PR = "r1"
6
7 SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
8            file://m4-warning.patch;patch=1 \
9           "
10
11 PARALLEL_MAKE=""
12
13 inherit autotools
14
15 do_configure() {
16         gnu-configize
17         oe_runconf
18 }
19
20 do_stage() {
21         oe_libinstall -so libpth ${STAGING_LIBDIR}
22
23         install -d ${STAGING_INCDIR}/
24         for X in pth.h
25         do
26                 install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
27         done
28
29         install -d ${STAGING_DATADIR}/aclocal
30         install pth.m4 ${STAGING_DATADIR}/aclocal/
31 }