Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / psplash / psplash_svn.bb
1 DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
2 HOMEPAGE = "http://projects.o-hand.com/psplash"
3 SECTION = "base"
4 LICENSE = "GPL"
5 PV = "0.0+svnr${SRCREV}"
6 PR = "r13"
7 RDEPENDS = "initscripts"
8
9 # You can create your own pslash-hand-img.h by doing
10 # ./make-image-header.sh <file>.png HAND
11 # and rename the resulting .h to pslash-hand-img.h (for the logo)
12 # respectively psplash-bar-img.h (BAR) for the bar.
13 # You might also want to patch the colors (see patch)
14
15 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
16           file://psplash-hand-img.h \
17           file://psplash-bar-img.h \
18           file://psplash-init"
19 S = "${WORKDIR}/psplash"
20
21 # This really should be default, but due yo openmoko hack below, can't be easily
22 SRC_URI_append_angstrom = " file://logo-math.patch;patch=1 "
23 SRC_URI_append_openmoko = " file://configurability.patch;patch=1 "
24
25 inherit autotools pkgconfig update-rc.d
26
27 do_configure_append() {
28         install -m 0644 ${WORKDIR}/psplash-hand-img.h ${S}/
29         install -m 0644 ${WORKDIR}/psplash-bar-img.h ${S}/
30 }
31
32 do_install_prepend() {
33         install -d ${D}/mnt/.psplash/
34         install -d ${D}${sysconfdir}/init.d/
35         install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
36 }
37
38 INITSCRIPT_NAME = "psplash"
39 INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
40
41 FILES_${PN} += "/mnt/.psplash"