Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / powervr-drivers / omap3-sgx-modules_1.3.13.1397.bb
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
3
4 PR = "r6"
5
6 inherit module
7
8 SRC_URI = "http://dominion.thruhere.net/koen/OE/omap3-sgx-modules-${PV}.tar.bz2 \
9            file://0001-Compile-fixes-for-DSS2.patch;patch=1 \
10            file://0001-New-build-system-for-SGX.patch;patch=1 \
11            file://spurious-irq-fix.diff;patch=1 \
12 "
13
14 PVRBUILD = "release"
15
16 MAKE_TARGETS = " BUILD=${PVRBUILD}"
17
18 do_compile_prepend() {
19         find ${S} -name "*.*o" | xargs rm
20 }
21
22 do_install() {
23         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
24         cp ${S}/pvrsrvkm.ko ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
25 }