bb files: Revert the introduction of FILE_PR
[vuplus_openembedded] / packages / povray / povray_3.6.1+3.7.0-beta25b.bb
1 DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
2 HOMEPAGE = "http://www.povray.org"
3 SECTION = "console/graphics"
4 LICENSE = "povray"
5 DEPENDS = "virtual/libx11 boost zlib jpeg libpng tiff"
6
7 PR = "r1"
8
9 #We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
10 SRC_URI = "http://www.povray.org/redirect/www.povray.org/beta/source/povray-src-3.7.0.beta.25b.tar.bz2 \
11            file://configure-cross-hack.patch;patch=1 \
12            file://gcc43.diff;patch=1 \
13            "
14
15 S = "${WORKDIR}/povray-3.7.0.beta.25b"
16
17 inherit autotools pkgconfig
18
19 EXTRA_OECONF = " --with-boost-thread=boost_thread-mt \
20                 COMPILED_BY=${MAINTAINER} "
21
22 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -O3 -ftree-vectorize  -ffast-math -fno-math-errno "
23
24 PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
25
26 PACKAGE_ARCH_${PN}-doc = "all"
27
28 PACKAGE_ARCH_${PN}-scenes = "all"
29 FILES_${PN}-scenes = "${datadir}/povray-3.7/scenes"
30
31 PACKAGE_ARCH_${PN}-ini = "all"
32 FILES_${PN}-ini = "${datadir}/povray-3.7/ini"
33
34 PACKAGE_ARCH_${PN}-icons = "all"
35 FILES_${PN}-icons = "${datadir}/povray-3.7/icons"
36
37 PACKAGE_ARCH_${PN}-scripts = "all"
38 FILES_${PN}-scripts = "${datadir}/povray-3.7/scripts"
39
40 PACKAGE_ARCH_${PN}-includes = "all"
41 FILES_${PN}-includes = "${datadir}/povray-3.7/include"
42