Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / portmap / portmap_6.0.bb
1 require portmap.inc
2
3 FILE_PR = "r3"
4
5 SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
6            file://destdir-no-strip.patch;patch=1 \
7            file://no-tcpd-support.patch;patch=1 \
8            file://no-libwrap.patch;patch=1;pnum=0 \
9            file://portmap.init "
10
11 # Remove this patch when SlugOS upgrades to binutils 1.18
12 SRC_URI_append_slugos = " file://no-pie.patch;patch=1 "
13
14 S = "${WORKDIR}/${PN}_${PV}/"
15
16 CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS"
17
18 fakeroot do_install() {
19     install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d
20     install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
21     oe_runmake install DESTDIR=${D}
22 }