Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / pkgconfig / pkgconfig_0.15.0.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "pkg-config is a system for managing library \
3 compile/link flags that works with automake and autoconf. \
4 It replaces the ubiquitous *-config scripts you may have \
5 seen with a single tool."
6 HOMEPAGE = "http://www.freedesktop.org/software/pkgconfig/"
7 LICENSE = "GPL"
8 FILE_PR = "r2"
9
10 SRC_URI = "http://www.freedesktop.org/software/pkgconfig/releases/pkgconfig-${PV}.tar.gz \
11            file://configure.patch;patch=1 \
12            file://pkg.m4 \
13            file://glibconfig-sysdefs.h"
14
15 inherit autotools 
16
17 acpaths = "-I ."
18 do_configure_prepend () {
19         install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
20         install -m 0644 ${WORKDIR}/pkg.m4 ${S}/
21 }
22
23 do_stage_append() {
24         install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
25
26 }