conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / php / php_5.1.4.bb
1 SECTION = "console/network"
2 DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
3 LICENSE = "PHP"
4 DEPENDS = "zlib libxml2 mysql libiconv"
5 SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
6                file://autotools.patch;patch=1"
7 S = "${WORKDIR}/php-${PV}"
8 PR = "r1"
9
10 inherit autotools
11
12 export THREADS="pthread"
13 export LIBS=" -lpthread "
14
15 CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
16 EXTRA_OECONF = "--without-iconv \
17                             --enable-discard-path \
18                             --enable-sockets \
19                     --enable-memory-limit \
20                     --enable-wddx \
21                     --with-zlib"
22
23 EXTRA_OECONF += " --without-pear"
24 # Uncomment the following two lines, and comment the above to enable PEAR
25 #EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR}/php"
26 #DEPENDS += " php-native"
27
28 acpaths = ""
29
30 do_configure_append() {
31     find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
32     find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
33 }
34
35 do_install  () {
36         oe_runmake 'INSTALL_ROOT=${D}' install
37 }