merge of '2641af179102d54034675cfdb4e90ed8d63ee913'
[vuplus_openembedded] / packages / php / php_5.1.4.bb
1 require php.inc
2
3 PR = "r3"
4
5 inherit autotools
6
7 export THREADS="pthread"
8 export LIBS=" -lpthread "
9
10 EXTRA_OECONF = "--without-iconv \
11                 --enable-discard-path \
12                 --enable-sockets \
13                 --enable-memory-limit \
14                 --enable-wddx \
15                  --with-zlib"
16
17 EXTRA_OECONF += " --without-pear --with-libxml-dir=${STAGING_BINDIR} "
18 # Uncomment the following two lines, and comment the above to enable PEAR
19 #EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR_NATIVE}/php"
20 #DEPENDS += " php-native"
21
22 do_configure_append() {
23     find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
24     find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
25 }